У меня при использовании php клиента к системе не показываются графики, что делать?




Скачать 102.09 Kb.
НазваниеУ меня при использовании php клиента к системе не показываются графики, что делать?
ТипВопрос
rykovodstvo.ru > Руководство эксплуатация > Вопрос
Часто задаваемые вопросы по настройке и использованию LANBilling (FAQ)



У меня при использовании PHP клиента к системе не показываются графики, что делать?

Данные не заносятся в БД MySQL, почему ?

Можно ли с помощью LANBilling считать не только кто, когда и сколько пользовался IP но и на вопрос какими ресурсами?

Могу ли я учитывать трафик сетей маски которых отличаются от 255.255.255.0?

Когда планируется выход LANBilling 1.4 ?

Может ли система собирать статистику с устройств CISCO?

Работает ли система на FreeBSD, OpenBSD?

Поддерживаются ли другие СУБД кроме MySQL?

Планируете ли Вы поддержку SNMP?

Планируете ли Вы получение сертификата “СВЯЗЬ” для LANBilling

Какое устройство CISCO и версию IOS мне необходимо иметь, что бы использовать возможность передачи статистических данных по протоколу NetFlow?

Как мне настроить мой маршрутизатор Cisco, что бы он отсылал информацию о трафике, который через него проходит на адрес сервера статистики, на котором установлен сетевой агент NetFlow версии LANBilling 1.5 Build 3?

Как я могу понять, что NetFlow поток уже направлен и корректно приходит на адрес который я указал в качестве адреса назначения потока?

Какие требования к аппаратной части предъявляет АСР LANBilling?

В чем может быть причина расхождений в показаниях АСР LANBilling и биллинговой системы, установленной у провайдера верхнего уровня?

Q) У меня при использовании PHP клиента к системе не показываются графики, что делать?
A) Наиболее вероятной причиной является отсутствие у PHP модуля Apache (или его CGI аналога) возможности работать с библиотекой GD. Для того что бы графики показывались, необходимо убедиться в работоспособности GD. Это можно сделать следующим образом. Необходимо создать файл с расширением .php в каталоге, доступном Apache со следующим кодом:

header ("Content-type: image/png");
$im = @ImageCreate (50, 100)
or die ("Cannot Initialize new GD image stream");
$background_color = ImageColorAllocate ($im, 255, 255, 255);
$text_color = ImageColorAllocate ($im, 233, 14, 91);
ImageString ($im, 1, 5, 5, "A Simple Text String", $text_color);
ImagePng ($im);
?>

Если после вызова этого файла из браузера Вы не увидели надписи "A Simple Text String", следовательно, причина однозначно в GD.
При сборке GD 1.8+ полезно разрешить jpeg в Makefile до этапа компиляции: -ljpeg
Мы используем следующие параметры компиляции PHP и Apache при программировании и отладке.
Находясь в дереве исходного кода Apache:

./configure

затем сборка PHP:

cd ../php-4.0.4 && ./configure --with-apache=../apache_1.3.14rusPL30.0 --with-mysql --enable-track-vars --with-gd --with-jpeg-dir --enable-gd-native-ttf && make && make install

сборка Apache:

cd ../apache_1.3.14rusPL30.0 && ./configure –prefix=/usr/local/apache –activate-module=src/modules/php4/libphp4.a && make && make install

Q) Данные не заносятся в БД MySQL, почему ?
A) Это может происходить по ряду причин, но наиболее вероятной могут быть следующие:
- не запускается /usr/local/bin/net-acct вследствие того, что вызов net-acct стоит последней строчкой в /etc/crontab, и за этой строкой нет символа “новая строка”.
- / usr/local/bin/net-acct запускается, однако содержащаяся в нем инструкция запуска основного модуля logwatcher_v.X.X.php не отрабатывает вследствие того что:

а) php транслятор не находится в /usr/bin
б) logwatcher_v.X.X.php не находится по тому пути который указан в /usr/local/bin/net-acct

Если это так то замените пути на те, которые используются в Вашей инсталляции.

Q) Можно ли с помощью LANBilling считать не только кто, когда и сколько пользовался IP но и на вопрос какими ресурсами?
А) Да, начиная с версии LANBilling 1.4 , однако это влечет за собой модернизацию структуры БД и увеличение ее объема.

Q) Могу ли я учитывать трафик сетей маски которых отличаются от 255.255.255.0 ?
А) Да, но только с выходом версии LANBilling 1.4

Q) Когда планируется выход LANBilling 1.4 ?
A) В конце октября, начале ноября 2001 года

Q) Может ли система собирать статистику с устройств CISCO?
A) Да, начиная с версии 1.5 build 2

Q) Работает ли система на FreeBSD, OpenBSD?
A) Некоммерческая версия нет, это ограничение накладывается ПО net-acct , и пока мы не откажемся от его использования совсем, проблема с портированием LANBilling на FreeBSD останется. Однако нам известно, что прецеденты портирования net-acct на FreeBSD существуют. При замене net-acct на версию для FreeBSD система будет работать
A) Коммерческая версия да.

Q) Поддерживаются ли другие СУБД кроме MySQL?
А) Некоммерческая версия нет
A) Коммерческая версия реализована с использованием библиотеки LibDbi, на сегодняшний день кроме MySQL поддерживается PostgreeSQL, остальные СУБД могут поддерживаться при наличии у производителя или у сторонних разработчиков плагина (plugin) для LibDbi. Сетевой агент в коммерческой версии совмещает в себе снятие данных с интерфейса и занесение их в БД.
 
 

Q) Планируете ли Вы поддержку SNMP?
А) Да, в первую очередь будет осуществляться поддержка устройств NSG, ориентировочный срок выхода модуля конец ноября 2003 г.

Q) Планируете ли Вы получение сертификата “СВЯЗЬ” для LANBilling
А) Сертификат получен 08.04.2003 для версии LANBilling 1.7

20.03.2002

Q) Какое устройство CISCO и версию IOS мне необходимо иметь, что бы использовать возможность передачи статистических данных по протоколу NetFlow?

А) В таблице приведены требования к программным и аппаратным компонентам маршрутизатора.

Cisco IOS Release

Supported Cisco Hardware Platform(s)

Supported NetFlow Export Version(s)

11.1 CA and 11.1 CC

Cisco 7200, 7500, and RSP7000

V1 and V5

11.2 and 11.2 P

Cisco 7200, 7500, and RSP7000

V1

11.2 P

Cisco Route Switch Module (RSM)

V1

11.3 and 11.3 T

Cisco 7200, 7500, and RSP7000

V1

12.0

Cisco 1720, 2600, 3600, 4500, 4700, AS5800, 7200, uBR7200, 7500, RSP7000, and RSM

V1 and V5

2.0 T

Cisco 1720, 2600, 3600, 4500, 4700, AS5800, 7200, uBR7200, 7500, RSP7000, RSM, MGX 8800 RPM, and BPX 8600

V1 and V5

12.0(3)T

and later Cisco 1600 1 , 1720, 2500 1 , 2600, 3600, 4500, 4700, AS5800, 7200, uBR7200, 7500, RSP7000, RSM, MGX8800 RPM, and BPX 8650

V1, V5, and V8

12.0(6)S

Cisco 12000

V1, V5, and V8

12.0(8)T

Cisco AS5300

V1, V5, and V8



Cisco Catalyst 5000 family switches with NetFlow Feature Card (NFFC)2

V7



Cisco Catalyst 6000 family switches with Multilayer Switching Feature Card (MSFC)

V7

Примечание: текущая версия сетевого агента поддерживает NetFlow V.5

Q) Как мне настроить мой маршрутизатор Cisco, что бы он отсылал информацию о трафике, который через него проходит на адрес сервера статистики, на котором установлен сетевой агент NetFlow версии LANBilling 1.5 Build 3?

А) Существует два принципиально отличающихся варианта, с точки зрения сбора статистики, организации доступа в интернет через маршрутизатор CISCO Systems. С использованием NAT (трансляции адресов) и без.

Вариант чистой маршрутизации.

Здесь мы рассматриваем вариант настройки CISCO 2600 который оборудован двумя Ethernet интерфейсами (Ethernet0/0 и Ethernet0/1), к одному из которых подключен канал интернет, к другому локальная сеть. Для того, что бы иметь возможность конфигурировать CISCO вы должны обладать паролями доступа к маршрутизатору и enable паролем для изменения конфигурации.

Находясь в командном режиме необходимо выполнить следующие команды:

conf t

interface e0/0

ip route-cache flow (Выйти из режима конфигурирования интерфейса CTRL-C)

interface e0/1

ip route-cache flow (Выйти из режима конфигурирования интерфейса CTRL-C)

ip flow-export IP.ADDRESS.OF.NETWORKAGENT 7223 version 5

далее перейдя в командный режим дать инструкцию сохранения настроенной конфигурации

copy ru sta

подтвердив сохранение конфигурации нажатием ENTER.

где IP.ADDRESS.OF.NETWORKAGENT заменить на IP адрес сервера, на котором установлен соответствующий сетевой агент.

Далее приводится пример конфигурации маршрутизатора на котором мы проводили тестирование сетевого агента. Обратите внимание, на этом устройстве настроен режим NAT (маскирование). Для корректной настройки NetFlow в случае с NAT см. следующий пункт.

---------- show running-config ------------
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5
!
ip subnet-zero
!
interface Ethernet0/0
ip address 62.117.67.XX 255.255.255.248
ip nat outside
ip route-cache flow
half-duplex
!
interface Ethernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip route-cache flow
half-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip flow-export version 5
ip flow-export destination 213.247.131.XX 7223
ip classless
ip route 0.0.0.0 0.0.0.0 62.117.67.XX
no ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
exec-timeout 5 0
password
login
!
no scheduler allocate
end

Вариант работы маршрутизатора в режиме NAT (транслирования адресов).

В качестве объяснения процесса настройки правильной регистрации статистики приведем пример (конфиг) маршрутизатора CISCO который использует NAT. В случае если Вы не обладаете опытом настройки устройств Cisco Systems и при настройке Вашего маршрутизатора Вы не можете добиться его корректной работы по сбору статистики обратитесь к квалифицированной помощи специалистов Вашего провайдера, или нашей компании. В любом случае при конфигурировании мы не рекомендуем сохранять конфигурацию маршрутизатора командой copy ru sta, до тех пор, пока Вы не убедитесь в его корректной работе.

---------- show running-config ------------
Cisco#show run
Building configuration...
Current configuration : 1531 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco
!
enable password cisco
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
!
call rsvp-sync
!
!
controller E1 0/0
clock source internal
channel-group 0 timeslots 1-2
!
controller E1 0/1
!
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
ip route-cache policy
ip route-cache flow
!
interface FastEthernet0/0
ip address 172.16.200.231 255.255.0.0
ip nat inside
ip route-cache policy
ip route-cache flow
duplex auto
speed auto
!
interface Serial0/0:0
ip address 172.20.0.2 255.255.0.0
ip nat outside
ip route-cache policy
ip route-cache flow
ip policy route-map priv-acco
!
!
ip nat pool NatPool 172.20.0.2 172.20.0.2 netmask 255.255.255.0
ip nat inside source list 1 pool NatPool overload
ip flow-export version 5
ip flow-export destination 172.16.0.90 8777
ip classless
ip http server
ip pim bidir-enable
!
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 2 permit 172.20.0.1
access-list 2 permit 172.20.0.2
access-list 2 permit 172.16.0.96
access-list 101 permit ip any 172.16.0.0 0.0.255.255
route-map priv-acco permit 1
set interface Loopback0
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password cisco
login
!
end

Q) Как я могу понять, что NetFlow поток уже направлен и корректно приходит на адрес который я указал в качестве адреса назначения потока?

А) Не устанавливая LANBilling вы можете убедиться в том, что пакеты приходят от маршрутизатора используя утилиту tcpdump – http://www.tcpdump.org (под linux) и NetXRay (для Windows)

В случае linux, принимая ETH0 интернет интерфейсом необходимо дать команду:

tcpdump –i eth0 port 7223

Следующий вывод будет свидетельствовать о корректной настройке маршрутизатора

[root@hole vlad]# tcpdump -i eth2 port 7223
Kernel filter, protocol ALL, datagram packet socket
tcpdump: listening on eth2
13:26:05.380650 < 62.117.67.37.57270 > 213.247.131.51.7223: udp 72
13:26:29.745134 < 62.117.67.37.57270 > 213.247.131.51.7223: udp 264

08.09.2003

Q) Какие требования к аппаратной части предъявляет АСР LANBilling?

А) Существует два варианта при подходе к планированию системы c точки зрения ее предполагаемой производительности:

  1. первый в расчете на то, что весь трафик всех клиентов будет детализироваться по портам и удаленным ресурсам (этого требует, например, применение специальных тарифов, позволяющих расчитывать различные удаленные сети/порты по отдельным деньгам). Потенциально узким местом в этом случае может быть лишь ядро MySQL на сервере БД, который будет вынужден хранить большое количество записей в таблицах с дневным трафиком, сам этот факт не несет никаких неприятностей, однако, работа с БД, как со стороны системы, так и со стороны администратора может стать причиной задержек/отказов в случае если аппаратура не удовлетворяет требованиям MySQL в случае применения MySQL для хранения очень больших массивов данных. В этом варианте мы не рекомендуем под сервер системы отводить менее чем P4-2.4/1024Mб RAM лучше всего, если это будет Dual P4/ + 2Gb RAM

  2. второй вариант: если детализация трафика применяется эпизодически и не для всех виртуальных групп, тогда для сервера АСР LANBilling можно обойтись и P3/512 RAM - меньшая конфигурация не подходит ввиду того, что на сегодняшний момент как по функциональности там и по требованиям к аппаратуре Mysql медленно, но верно приближается к Oracle.

В обоих случаях в качестве сервера доступа, можно обойтись P3/512 RAM или даже 256 RAM, т.к. агент сам по себе не предъявляет особых требований к аппаратуре, он способен заложить в БД весь объем информации, который проходит по интерфейсам, однако этот объем нужно обрабатывать. Не всякая система позволит обработать с полной детализацией например E1 поток (2 Mбит/c).

Комментарии к выбору аппаратной части

Q) В чем может быть причина расхождений в показаниях АСР LANBilling и биллинговой системы, установленной у провайдера верхнего уровня?

А) Существует множество причин по которым статистические данные, получаемые при помощи АСР LANBilling отличаются от данных биллинговой системы провайдера верхнего уровня как в большую так и в меньшую сторону. Основными причинами являются следующие:

  • Формальное различие между каналами связи с которых осуществляется сбор статистики использования услуг доступа к ресурсам IP сети провайдером верхнего уровня и оператором, эксплуатирующим LANBilling. В частности, в случае если сбор статистики оператором осуществляется с внутреннего интерфейса Ethernet маршрутизатора, построенного на UNIX платформе, данный тарифицируемый канал связи не является тем же самым каналом, тарификацию которого осуществляет провайдер верхнего уровня. Следствием этого может быть различие в показаниях систем.

  • Различие методов (средств, способов) которыми осуществляется тарификация канала связи провайдером верхнего уровня и оператором. Разница в данном случае обусловлена тем, что в зависимости от тех или иных средств снятия статистики, объем пакетов, регистрируемых системой провайдера может отличаться от объема пакетов, регистрируемых оператором, применяющим LANBilling. Например, аппаратура коммутации в сети провайдера может вносить изменения в Ethernet пакеты, которые, как известно имеют переменную длину. В результате чего, при одном и тоже объеме полезных данных, переданных по каналу, объем служебных данных различен (служебными считаются данные заголовков инкапсулированных пакетов различных уровней ЭМВОС-OSI). Так же возможна разница в случае если ПО провайдера верхнего уровня регистрирует все пакеты, проходящие по каналу, на втором уровне (канальном), в то время как LANBilling работает на уровне 3 (сетевом).

  • Неадекватность аппаратуры, применяемой для нужд тарификации средствами АСР LANBilling, стоящим перед системой задачам. А именно, в случае если ресурсов аппаратной части недостаточно для нормального функционирования системы (агентов сбора данных), разница в данных между биллинговой системой провайдера и оператора может быть обусловлена частичными потерями статистических данных, ввиду проблем с производительностью аппаратуры. Типичным случаем является применение единой аппаратной платформы в условиях применения агента Ethernet совместно с алгоритмами трансляции адресов, в том случае если агент и NAT(Masquerade) функционируют на одном и том же Ethernet интерфейсе. Подробнее см. ссылку.

  • Некоррекность настройки АСР LANBilling персоналом оператора. Типичным примером является указание в настройке сетевых агентов АСР не всех IP сетей трафик которых имеет место в сетевой инфраструктуре оператора.

  • Субъективные причины, такие как ошибки в функционировании программно-аппаратных комплексов как провайдера верхнего уровня так и оператора, применяющего АСР LANBilling.

  • Разница в трактовке термина 1 КИЛОбайт. Часть провайдеров в качестве 1Кб принимают 1000 байт, часть провайдеров работают со значением 1024 байт.

Наша компания не гарантирует соответствия статистичеких данных провайдера верхнего уровня, данным полученным при помощи АСР LANBilling ввиду вышеуказанных причин. Как следствие этого, указанное различие не может являться критерием для принятия решения о некорректности тарификации средствами АСР LANBilling. А также быть поводом для претензий в адрес производителя, относительно работы алгоритмов АСР, функциональная корректность которых была подтверждена испытательной лабораторией в ходе сертификационных испытаний, по системе сертификации Связь (ССС).

Похожие:

У меня при использовании php клиента к системе не показываются графики, что делать? iconИнструкция по загрузке файлов через ftp в качестве ftp-клиента можно...
В качестве ftp-клиента можно использовать far manager, при использовании другого ftp-клиента необходимо учитывать его особенности...

У меня при использовании php клиента к системе не показываются графики, что делать? iconВаш клиент
«шинели». Советское предприятие было ориентировано не на клиента, а на «план». А посему не стоит удивляться тому, что мы вошли в...

У меня при использовании php клиента к системе не показываются графики, что делать? iconРегламент предоставления услуг по дистанционному банковскому обслуживанию...
...

У меня при использовании php клиента к системе не показываются графики, что делать? iconИнструкция по эксплуатации спасибо, что остановили свой выбор на...
После прочтения настоящей инструкции по эксплуатации и при использовании своего ручного блендера в соответствии с указаниями вы убедитесь,...

У меня при использовании php клиента к системе не показываются графики, что делать? iconРуководство пользователя по регистрации в системе iBank2 V 1 Регистрация...
В настоящей инструкции подробно описана процедура регистрации в системе «iBank 2» нового клиента юридического лица заключившего договор...

У меня при использовании php клиента к системе не показываются графики, что делать? iconHow To : Совместная работа ps 2 Linux и hd advance
Предупреждение: Только не надо делать меня крайним, если у вас что-то не получается. Я написал это руководство, будучи не в своем...

У меня при использовании php клиента к системе не показываются графики, что делать? iconМоу «сош» с. Керес Керес, 2016 Ответы на вопросы викторины
Я прикинул, что уже час нахожусь под чистым кислородом, и кипения быть не должно. Чего я побоялся, то это паники на Земле. Начали...

У меня при использовании php клиента к системе не показываются графики, что делать? iconИнструкция по эксплуатации при использовании своего утюга вы поймете...
После прочтения настоящей инструкции по эксплуатации и при использовании своего утюга в соответствии с указаниями вы убедитесь, что...

У меня при использовании php клиента к системе не показываются графики, что делать? iconОбщие правила построения php-программы
Популярные html-редакторы имеют встроенную поддержку для редактирования php-программ

У меня при использовании php клиента к системе не показываются графики, что делать? iconРабота с электронной почтой
Ндфл, произвольных файлов. Работа с отправленными отчетами: что делать, если получен протокол проверки с ошибками; как сохранить...

У меня при использовании php клиента к системе не показываются графики, что делать? iconИнструкция по чтению “Отчета по клиентскому счету “ (срочный рынок) Общая часть
Номер счета Клиента на срочном рынке в торговой системе, наименование клиента, номер и дата брокерского договора с Компанией

У меня при использовании php клиента к системе не показываются графики, что делать? iconПервостепенную значимость при любой чрезвычайной ситуации имеет не...
Главная опасность для вас кроется в ваших же поспешных необдуманных действиях. Ведь не природа виновата в том, что ударяет по человеку...

У меня при использовании php клиента к системе не показываются графики, что делать? iconЛабораторная работа № Основы синтаксиса php
В отличие от традиционных скриптовых языков (таких, как Perl), php-программа представляет собой html-страницу со вставками кода....

У меня при использовании php клиента к системе не показываются графики, что делать? iconЕсть множество книг, которые учат тому, что нужно делать специалисту...
Как это делать. Эта книга как раз о том, как соединить маркетинговую теорию с реальной жизнью коммерческого предприятия и добиться...

У меня при использовании php клиента к системе не показываются графики, что делать? iconЕсли возникло возгорание, что делать?
Если возникло возгорание, что делать? Надо постараться потушить огонь, пока он не разгорелся основательно. Но как это сделать? Для...

У меня при использовании php клиента к системе не показываются графики, что делать? iconРаспространялась в России, в основном, при помощи почтовой рассылки....
России, в основном, при помощи почтовой рассылки. Однако прошло время, и я, автор этой книги, решил её переписать. У меня появились...


Руководство, инструкция по применению






При копировании материала укажите ссылку © 2018
контакты
rykovodstvo.ru
Поиск